Opened 10 years ago

Closed 10 years ago

#3468 closed Bug (fixed)

Syntax errors in trunk code is causing editor to crash in IE6, 7

Reported by: Martin Kou Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: Review+ Cc:

Description

To reproduce:

  1. Open replacebyclass.html today's trunk code in IE6 or 7.
  2. JavaScript error.

Attachments (1)

3468.patch (1.5 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Martin Kou

Attachment: 3468.patch added

comment:1 Changed 10 years ago by Martin Kou

Keywords: Review? added

The error is due to a dangling semicolon near the end of element.js. I've fixed some other lint reported syntax errors in the core with the patch as well.

comment:2 Changed 10 years ago by Martin Kou

Summary: Syntax errors in trunk code is causing editor is crash in IE6, 7Syntax errors in trunk code is causing editor to crash in IE6, 7

comment:3 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:4 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [3461].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy