Opened 11 years ago

Closed 10 years ago

#3485 closed Bug (invalid)

When pressing the backspace key, it puts  

Reported by: Ignatius Winarto Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.4
Keywords: Cc:

Description

It puts   in where you have used the backspace key when editing.

Change History (3)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Pending added

Could you provide steps to reproduce this bug?

comment:2 Changed 10 years ago by Ignatius Winarto

Actually, I just realised the backspace has got nothing to do with this. The   character appears when you press spacebar twice (or more), and so if you press spacebar twice then press backspace to correct it (i.e., you only meant it to be a single spacebar stroke), then you are left with   character in place of the first spacebar key stroke.

comment:3 Changed 10 years ago by Garry Yao

Keywords: Pending removed
Resolution: invalid
Status: newclosed

I think it's not a bug, actually some browser collapse multiple, concurrent spaces into a single space, so always inserting spaces is not appropriate, so whenever you press 'space key', browser will:

  1. Insert a normal space if there's no space around;
  2. Otherwise insert  

This could guarantee that the visual spaces is always maintained and the line-break could be respected also.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy