Opened 11 years ago

Closed 11 years ago

#3488 closed Bug (fixed)

Safari: Cell context menu doesn't always work

Reported by: Damian Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Confirmed Review+ Cc:

Description

Steps to reproduce:

  1. Open ajax sample
  2. Create table with default values
  3. Right click in a cell to invoke context menu.
  4. Attempt access the cell sub-menu.


Actual result:
Cell sub-menu doesn't display.

Attachments (1)

3488.patch (2.3 KB) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed added

comment:2 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 11 years ago by Martin Kou

Attachment: 3488.patch added

comment:3 Changed 11 years ago by Martin Kou

Keywords: Review? added

The culprit is a simple logical error in the getSelectedCells() that can be fixed by modifying the single line of code. However, since range.getBoundaryCells() is to be deprecated, I've converted the whole function's logic to use the DOM walker instead.

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3491].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy