Opened 11 years ago

Closed 11 years ago

#3490 closed Bug (fixed)

Context menu does not display properly in IE6.

Reported by: Damian Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Confirmed IE6 Review+ Cc:

Description

Reproduced on latest nightly Ajax sample. Please refer to attached image.

Attachments (4)

columnContextMenu.png (20.0 KB) - added by Damian 11 years ago.
3490.patch (1.2 KB) - added by Martin Kou 11 years ago.
3490_2.patch (1.5 KB) - added by Martin Kou 11 years ago.
3490_3.patch (1.5 KB) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by Damian

Attachment: columnContextMenu.png added

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed IE6 added
Summary: Column sub-menu does not display properly in IE6.Context menu does not display properly in IE6.

The whole context menu does not display properly in IE6.

It can be related to #3494

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

It looks like the menu items text are being forced to wrap.

comment:3 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 11 years ago by Martin Kou

Attachment: 3490.patch added

comment:4 Changed 11 years ago by Martin Kou

Keywords: Review? added

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The patch is ok to fixing the arrow issue, but it's still missing the undesired wrap in the submenu items.

Changed 11 years ago by Martin Kou

Attachment: 3490_2.patch added

comment:6 Changed 11 years ago by Martin Kou

Keywords: Review? added; Review- removed

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The patch is mostly ok. Just that static 86px in the css that disturbs me. So, let's reduce the impact of it. Please replace the "width" property with "_width". In this way we restrict this hack to our dear IE6 only.

Changed 11 years ago by Martin Kou

Attachment: 3490_3.patch added

comment:8 Changed 11 years ago by Martin Kou

Keywords: Review? added; Review- removed

comment:9 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:10 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3492].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy