Opened 8 years ago

Closed 8 years ago

#3503 closed New Feature (fixed)

New default skin for V3

Reported by: Frederico Caldeira Knabben Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed 3.0RC Review+ Cc: fckeditor@…

Description

With V3 we'll be introducing a brand new skin. It will be the default one. The old V2 (V1!) one will still be available as an option.

Attachments (2)

kama.zip (17.6 KB) - added by Tobiasz Cudnik 8 years ago.
Extract to "_source/skins"
3503.patch (69.9 KB) - added by Tobiasz Cudnik 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Josh Nisly

Cc: fckeditor@… added

comment:2 Changed 8 years ago by Tobiasz Cudnik

Owner: changed from Frederico Caldeira Knabben to Tobiasz Cudnik
Status: newassigned

After talk with Frederico and getting work-in-progress patch i'm taking over this ticket.

Changed 8 years ago by Tobiasz Cudnik

Attachment: kama.zip added

Extract to "_source/skins"

comment:3 Changed 8 years ago by Tobiasz Cudnik

For those interested how it looks like, check quick screencast in #3598.

comment:4 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3503.patch added

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

This first version is a very good progress for this feature. There are some quite evident issues though:

  • The context menu is not styled accordingly.
  • The floating panels have lost their height. All have the same height.

There are still some issues that we'll be discussing also.

comment:6 Changed 8 years ago by Tobiasz Cudnik

Patches for this and #3598 ticket are available in dedicated branch:
https://svn.fckeditor.net/CKEditor/branches/features/kama

comment:7 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review- removed
Resolution: fixed
Status: assignedclosed

Fixed with [3649].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy