Opened 11 years ago

Closed 11 years ago

#3506 closed Bug (fixed)

Combo panels do not align in FF

Reported by: Damian Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Confirmed Review+ Cc:

Description (last modified by Tobiasz Cudnik)

When selecting any of the Styles/Format/Font/Size combos, the panel is misplaced. It is slightly different for FF2 and FF3.
Reproduced on nightly build.

Attachments (3)

alignmentProblem.png (37.0 KB) - added by Damian 11 years ago.
3506.patch (1.1 KB) - added by Tobiasz Cudnik 11 years ago.
Tested in FF3.
3506_2.patch (497 bytes) - added by Tobiasz Cudnik 11 years ago.
Tested in FF3.

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by Damian

Attachment: alignmentProblem.png added

comment:1 Changed 11 years ago by Tobiasz Cudnik

Description: modified (diff)
Status: newassigned

comment:2 Changed 11 years ago by Tobiasz Cudnik

Keywords: Confirmed added
Owner: set to Tobiasz Cudnik

comment:3 Changed 11 years ago by Tobiasz Cudnik

Description: modified (diff)
Keywords: Review? added

FF doesn't stretch containers for floated contents if containers are empty (besides containing floated elements). This patch seems to fix it using only css, simply floating also containers. Althought this cant be applied for other browsers.

Changed 11 years ago by Tobiasz Cudnik

Attachment: 3506.patch added

Tested in FF3.

comment:4 in reply to:  3 Changed 11 years ago by Tobiasz Cudnik

Replying to tobiasz.cudnik:

FF doesn't stretch containers for floated contents if containers are empty (besides containing floated elements).

This description isn't really true, because floats generally doesn't stretch containers in normal cases. Problem with FF is that it incorrectly relocates container in our case.

comment:5 Changed 11 years ago by Martin Kou

Keywords: Review- added; Review? removed

The fix looks simple but it's not 100% working - we're aiming to get the position of the rich combo boxes pixel-perfect in the major browsers. Yet the rich combos' positions are still off by (-1px, -1px) in FF3 after the patch.

The rich combo bug in FF3 is actually a fairly recent regression bug - it was working perfectly in FF3 back in r3476, for example. Now we're only at r3500 and for some reason it's no longer working correctly. In cases like this, it is often helpful to know exactly which change caused the bug. It is much better to be able to fix the direct cause of the problem instead of adding an indirect CSS fix which doesn't exactly fix the problem.

It should be possible to trace down the change that caused the bug fairly quickly by checking out the revisions between r3476 and r3500 in a binary search pattern and testing them out.

Changed 11 years ago by Tobiasz Cudnik

Attachment: 3506_2.patch added

Tested in FF3.

comment:6 Changed 11 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

You're right Martin, this regression has been introduced in [3483]. There was missing offsetParent update after introduction of new element in DOM structure.

comment:7 Changed 11 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:8 Changed 11 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3504].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy