Opened 10 years ago

Closed 10 years ago

#3512 closed Bug (fixed)

Non-namespaced css class names

Reported by: Tobiasz Cudnik Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

There are many non-namespaced css class names in dialog.css and those are:

  • disabled
  • dark_background
  • LightBackground
  • DarkBackground
  • hand
  • Hand
  • centered
  • BtnReset
  • BtnUnlocked
  • BtnLocked
  • ImagePreviewBox
  • ImagePreviewLoader
  • LightBackground
  • FlashPreviewBox

I assume those are some legacy classes, but since dialog isn't placed inside an iframe, this can result in some serious complications.

Attachments (2)

3512.patch (17.7 KB) - added by Tobiasz Cudnik 10 years ago.
3512_2.patch (8.8 KB) - added by Tobiasz Cudnik 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: CKEditor 3.xCKEditor 3.0

I would make it fixed for the 3.0, so the impact on skins development will be less drastic.

Other than the "cke_" prefix, the styles names should follow the new naming schema having all lowercased with words separated by underscore.

comment:2 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3512.patch added

comment:3 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added

This patch fixes all classnames, but there are still IDs left. Now the question is should they be also fixed and whats the naming convention (if different). They are used in couple of places in source code.

comment:4 Changed 10 years ago by Martin Kou

Keywords: Review- added; Review? removed

The changes to the smiley dialog seems to be duplicate of #3492. Besides, there's still a class="hand" in the smiley dialog.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3512_2.patch added

comment:5 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

comment:6 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:7 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3546].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy