Opened 10 years ago

Closed 10 years ago

#3558 closed Task (wontfix)

Investigate alternatives to <a href="..."> tags for accessible interactive elements.

Reported by: Martin Kou Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: SVN (CKEditor) - OLD
Keywords: Confirmed Cc:

Description

Many interactive elements, such as toolbar buttons in CKEditor 3.0, use an <a href="javascript:void()"> tag due to the ability to get keyboard focus.

The <a href="..."> tags causes the UI elements to be pronounced as links in JAWS, which is usually inappropriate because the UI elements are in fact buttons.

Change History (3)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

We should much probably still use <a> for it, but have better ARIA support, specially for the "role" attribute.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1
Resolution: wontfix
Status: newclosed

This one is to be fixed by ARIA really, not specific element changes.

Note that <a> is used for IE6 only, and it's there for the hover effect exclusively.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy