Opened 10 years ago

Closed 10 years ago

#3563 closed Bug (fixed)

Disabled items have wrong style in menus

Reported by: Frederico Caldeira Knabben Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Review? Cc:

Description

In menus, like the context menu or menu buttons, the disabled items are styled improperly. The background color for the icons space should be colored just like the enabled ones, having instead the icon and the text semi-transparent.

Also, these items should not have hover state.

Attachments (1)

3563.patch (2.8 KB) - added by Tobiasz Cudnik 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3563.patch added

comment:2 Changed 10 years ago by Tobiasz Cudnik

This is temporally patch which disables hover effect.

Separate opacity for icon background and icon itself requires splitting icon node into 2 nodes. This is because icon, which is a background, can't have separate opacity setting from node which it's "backgrounding".

There is a quick'n'dirty workaround to modification described above, which is setting the dedicated background color which after applying opacity will give normal background in effect, but i would prefer to avoid such ways.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

It looks like we really need a change in the DOM structure (nested span) to get this fixed. Go ahead with it.

comment:4 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added

comment:5 Changed 10 years ago by Tobiasz Cudnik

Fix is provided in kama branch:
https://svn.fckeditor.net/CKEditor/branches/features/kama

Covers only new V3 skin. After approval other skins will have new menu with their own colors.

comment:6 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3649].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy