Opened 11 years ago

Closed 10 years ago

#3569 closed Bug (duplicate)

SCAYT should stop at form fields

Reported by: Garry Yao Owned by:
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Spell Checker Version:
Keywords: Confirmed HasPatch Cc: WebSpellChecker.net

Description

The 'scayt_word' marker should split words separated by form field elements, while it's not:

Reproducing Procedures

  1. Open the replace by class example page with SCAYT plugin enabled.
  2. Insert the text 'wrongword' into editor, waiting for SCAYT marking this word;
  3. Move the selection into 'wrong|word', click on 'Insert TextField' button to open dialog and insert a default textfield.
  4. Disable and re-enable the SCAYT plugin or enter some char to reload all markers.
    • Expected Result : wrong<input />word should not be considered to have spell error;
    • Actual Result : wrong<input />word is marked as spell error in a whole and if click on the first word to open context menu and click any of the suggestions, the in-middle textfield get lost along with these two words.

Attachments (1)

3569.patch (1.6 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Artur Formella

Resolution: duplicate
Status: newclosed

DUP of 3562

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.xCKEditor 3.0

comment:3 Changed 10 years ago by Garry Yao

Cc: WebSpellChecker.net added
Keywords: Confirmed Review? added
Resolution: duplicate
Status: closedreopened

It's not a DUP of #3562 but issue from inside SCAYT, the default word boundary elements definition from SCAYT is not enough for CKEditor, so we need to expand the range of these elements to include commonly appeared ones like <input> and <hr>.

Changed 10 years ago by Garry Yao

Attachment: 3569.patch added

comment:4 Changed 10 years ago by WebSpellChecker.net

The problem is inside SCAYT. We're going to update engine to process <input> the same way as <img> processed, so this problem should be degraded to DUP of #3562.

We are reviewing the ability to make split elements configuration accessible via public API, but this is subject not to current version.

comment:5 in reply to:  4 Changed 10 years ago by Garry Yao

Keywords: HasPatch added; Review? removed

Replying to SpellChecker.net:

The problem is inside SCAYT. We're going to update engine to process <input> the same way as <img> processed, so this problem should be degraded to DUP of #3562.

OK that's great, so please update this ticket when it get fixed in SCAYT engine.

comment:6 Changed 10 years ago by WebSpellChecker.net

We have updated the SCAYT core and the problem is resolved as specified above - degraded to DUP of #3562

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy