Opened 13 years ago

Closed 12 years ago

#361 closed Bug (fixed)

editor not restored when moving in history (Opera)

Reported by: Hallvord R. M. Steen (Opera Software) Owned by: Hallvord R. M. Steen (Opera Software)
Priority: Must have (possibly next milestone) Milestone: Opera Compatibility
Component: General Version:
Keywords: Cc:

Description

  • load editor
  • go to another page by typing in URL field
  • go back

Problem: editor does not re-appear.

Either Opera does not keep its state correctly, or it self-destroys by doing someting in onunload and doesn't get a load event to restore itself. I'm not sure which it is.

Change History (6)

comment:1 Changed 13 years ago by Kaare Byberg

Analysis shows that this is a history/page load bug in Opera, caused by a quite intricate code:

A page containing an iframe gets another iframe, created from within the first iframe. This new iframe's src is set to "javascript:void(0);" and is appended to the page's document before the original iframe. When accessing this page when navigating in history, the original iframe (and the new one) appears blank.

comment:2 Changed 13 years ago by Hallvord R. M. Steen (Opera Software)

this is probably ours too. seems we don't fire any unload events so it would be Opera's responsibility entirely to preserve DOM state.

comment:3 Changed 13 years ago by Hallvord R. M. Steen (Opera Software)

Owner: set to Hallvord R. M. Steen (Opera Software)
Status: newassigned

comment:4 Changed 13 years ago by Hallvord R. M. Steen (Opera Software)

General issue about not losing DOM state of designMode documents on history navigation filed as Opera bug 260789. However.. that may not cover this bug entirely, since the whole toolbar disappears and not just the designMode stuff..?

comment:5 Changed 13 years ago by Hallvord R. M. Steen (Opera Software)

Right, byberg's comment and test case for Opera's bug 260427 covers the rest of this issue. Thanks Kåre :)

comment:6 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Resolution: fixed
Status: assignedclosed

This particular issue is fixed. Opera does loose any text input when moving in history, so there still is work to do! I'll make sure there is another bug on that.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy