Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#360 closed Bug (fixed)

Form "name" is set to "[object]" if it contains a field with id="name"

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.4.3
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Cc: shane@…, victor@…

Description

Paste the following in the source view:

<form name="test">
    <input id="name" type="text" />
</form>

Switch to WYSIWYG and back to source. You will have name="[object]" in the form element.

It happens only because the "id" of the input element inside the form is set to "name" (casually the form attribute name).

Confimed with IE6. It's not a problem with FF2.

Change History (3)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5
Owner: set to Frederico Caldeira Knabben
Status: newassigned

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [262].

Click here for more info about our SVN system.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5FCKeditor 2.4.3
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy