Ticket #3616 (closed Bug: invalid)

Opened 5 years ago

Last modified 2 years ago

Copy/Paste in Safari and Chrome resulted in more <p> tags

Reported by: ambio Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version: FCKeditor 2.6.4
Keywords: Cc:

Description

When I copy a text of a <p> tag and I paste it, the generated HTML is incorrect. When I switch several times from editor mode into source mode, the HTML is correct but there are multiple <p> tags added.

Steps to reproduce the problem:

1) Go to source view and type <p>test</p> 2) Switch to editor view. Select the word test and use CTRL-C. 3) Type an enter 4) Use CTRL-V 5) Type an enter 6) Use CTRL-V 7) Go to source view (you will see P-tags inside P-tags) 8) Go to editor view (nothing is changed) 9) Go to source view (something has changed for the P-tags inside P-tags) 10) Go to editor view (nothing is changed) 11) Go to source view (P-tags inside P-tags are replaced by <p>&nbsp;</p>) 12) Go to editor view (you will additional enters after each word test)

Can this be fixed? Because this is an very annoying behavior.

Thanks in advance!

Change History

comment:1 Changed 5 years ago by ambio

  • Cc kvergeyle@… added

comment:2 Changed 5 years ago by ambio

  • Cc kvergeyle@… removed

comment:3 Changed 5 years ago by alfonsoml

  • Priority changed from High to Normal
  • Milestone FCKeditor 2.6.5 deleted

comment:4 Changed 2 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to invalid

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy