Opened 10 years ago

Closed 10 years ago

#3617 closed Bug (fixed)

Change list type incorrect

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Styles Version:
Keywords: Confirmed Review+ Cc:

Description

Reproducing Procedures

  1. Open the replace by class example page with enterMode = br in FF;
  2. Make the content and selection same as below:
    text<ol><li>ite^m1</li><li>ite^m2</li></ol>text
    
  3. Click on 'Bullet List' command to change the list type.
    • Expected Result:
      text<ul><li>item1</li><li>item2</li></ul>text
      
    • Actual Result: Javascript error thrown.

Attachments (2)

3617.patch (2.1 KB) - added by Garry Yao 10 years ago.
3617_2.patch (2.1 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Garry Yao

Attachment: 3617.patch added

comment:1 Changed 10 years ago by Garry Yao

Keywords: Confirmed Review? added
Owner: set to Garry Yao
Status: newassigned

The patch is including the fix at #3618 for easy reviewing.

Changed 10 years ago by Garry Yao

Attachment: 3617_2.patch added

comment:2 Changed 10 years ago by Garry Yao

Updating the reliance from #3618.

comment:3 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:4 Changed 10 years ago by Martin Kou

Since the fix to this ticket is the same as #3618, please mark this as fixed when #3618 is commited.

comment:5 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3605].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy