Opened 10 years ago

Closed 9 years ago

#3635 closed Bug (fixed)

Create list on whole paragraph incorrect

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: Core : Styles Version:
Keywords: Confirmed Cc:

Description

Reproducing Procedures

  1. Open the replace by class example page, load the document with the following content with selection;
    <p>
    	^paragraph1</p>
    <p>
    	paragraph2</p>
    
  2. Click on 'p' item on the elements path bar to fully select the first paragraph;
  3. Click on 'Numbered List' button to convert it to list;
    • Expected Result :
      [<ol>
      	<li>
      		paragraph1<br />
      	</li>
      </ol>]
      <p>
      	paragraph2</p>
      
    • Actual Result : There's an empty paragraph created above it.
      <p>
      	<br />
      </p>
      [<ol>
      	<li>
      		paragraph1<br />
      	</li>
      </ol>]
      <p>
      	paragraph2</p>
      

Change History (2)

comment:1 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

The fixing of this ticket has some conflict with #3608, which will be hold until #3608 get fixed.

comment:2 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Unable to reproduce anymore on trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy