Opened 8 years ago

Closed 8 years ago

#3642 closed Bug (fixed)

[IE7] File type form field layout incorrect

Reported by: Garry Yao Owned by: Artur Formella
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Dialogs Version:
Keywords: Confirmed Review+ Cc:

Description


Attachments (6)

IE7.png (3.3 KB) - added by Garry Yao 8 years ago.
Screenshot of IE7
IE8(IE7_DocMode).png (12.0 KB) - added by Garry Yao 8 years ago.
Screenshot of IE8
trunk_v2_ie7.png (12.2 KB) - added by Tobiasz Cudnik 8 years ago.
3642.patch (2.0 KB) - added by Artur Formella 8 years ago.
ff3-link-dialog.png (16.5 KB) - added by Tobiasz Cudnik 8 years ago.
3642_2.patch (2.6 KB) - added by Artur Formella 8 years ago.

Download all attachments as: .zip

Change History (18)

Changed 8 years ago by Garry Yao

Attachment: IE7.png added

Screenshot of IE7

comment:1 Changed 8 years ago by Garry Yao

Summary: File type form field layout incorrect[IE7] File type form field layout incorrect

comment:2 Changed 8 years ago by Tobiasz Cudnik

Keywords: Pending added

Can't reproduce this on IE7. What version is affected ?

From which dialog screenshot cames from ?

comment:3 Changed 8 years ago by Garry Yao

I've caught this with IETester's IE7 tab, and now I have witness on IE8 also, see the attached screenshot come from link dialog.

Changed 8 years ago by Garry Yao

Attachment: IE8(IE7_DocMode).png added

Screenshot of IE8

Changed 8 years ago by Tobiasz Cudnik

Attachment: trunk_v2_ie7.png added

comment:4 Changed 8 years ago by Tobiasz Cudnik

Keywords: Kama Pending removed

Not a Kama regression, exists in V2 and probably in Office2003 skins also.

comment:5 Changed 8 years ago by Artur Formella

Owner: set to Artur Formella
Status: newassigned

Changed 8 years ago by Artur Formella

Attachment: 3642.patch added

comment:6 Changed 8 years ago by Artur Formella

Keywords: Confirmed Review? added

Minimal solution in the patch. There is also a heavier solution: http://www.quirksmode.org/dom/inputfile.html

comment:7 Changed 8 years ago by Artur Formella

Tested on IE6,IE7,FF2,FF3, Opera 9.63, Safari 4, Chrome 0.4

Changed 8 years ago by Tobiasz Cudnik

Attachment: ff3-link-dialog.png added

comment:8 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review- added; Review? removed

On FF3 it still seems to be broken. Checked link dialog on kama and v2 skins.

Changed 8 years ago by Artur Formella

Attachment: 3642_2.patch added

comment:9 Changed 8 years ago by Artur Formella

Keywords: Review? added; Review- removed

comment:10 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review+ added; Review? removed

comment:11 Changed 8 years ago by Artur Formella

Fixed with [3845]

comment:12 Changed 8 years ago by Artur Formella

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy