Opened 10 years ago

Closed 10 years ago

#3665 closed Bug (invalid)

[IE] Output source code has extra  

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Output Data Version:
Keywords: IE Confirmed Review? Cc:

Description

Reproducing Procedures

  1. Open the replace by class example page in IE;
  2. Press 'Enter Key' to create a new paragraph;
  3. Switch to 'Source' mode;
    • Expected Result:
      <p>
      	This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">CKEditor</a>.</p>
      <p>
      </p>
      
      
    • Actual Result:
      <p>
      	This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">CKEditor</a>.</p>
      <p>
      	&nbsp;</p>
      

Attachments (1)

3665.patch (1.0 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by Garry Yao

Status: newassigned

This &nbsp; is created by IE on empty paragraph when retrieving through innerHTML, and it's definitely eval coz it change the original document editing experience.

Changed 10 years ago by Garry Yao

Attachment: 3665.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added

The patch is simply converting this:

<p>&nbsp;</p>

into

<p></p>

It's not a perfect solution because it has chance to conflict with user editing result, but seldom will user create a paragraph with such a pattern.

comment:3 Changed 10 years ago by Martin Kou

Resolution: invalid
Status: assignedclosed

I've just had a talk with Garry. This is actually not a bug - the &nbsp; is needed to make the <p> block visible outside of the editor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy