Opened 10 years ago

Closed 10 years ago

#3690 closed Bug (fixed)

Selection is lost after Enable SCAYT

Reported by: Garry Yao Owned by:
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Cc: WebSpellChecker.net

Description

Reproducing Procedures

  1. Open the replace by class example page in FF;
  2. Make a random selection;
  3. Enable 'SCAYT';
    • Expected Result: The selection remains the same.
    • Actual Result: The selection now collapsed at the start of document.

Change History (4)

comment:1 Changed 10 years ago by Garry Yao

The culprit here is the spell check markers is breaking the selection:

scayt_control.setDisabled( false ); //async

We need some callback function here to properly bookmark the range and restore it:

var sel = editor.getSelection(),
 bms = sel.createBookmarks();
scayt_control.setDisabled( false , function()
{
  // inside callback...
  sel.selectBookmarks( bms );
});

Not sure if we can do this with SCAYT engine API?

comment:2 Changed 10 years ago by WebSpellChecker.net

The problem is inside SCAYT engine. The behavior is expected to be as described: The selection remains the same. We're going to fix the problem inside the SCAYT engine.

comment:3 Changed 10 years ago by WebSpellChecker.net

We have updated the SCAYT core and the problem is resolved.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy