Opened 10 years ago

Closed 10 years ago

#3766 closed Bug (fixed)

In the context menu, long labels with second level menu get wrapped

Reported by: Frederico Caldeira Knabben Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Spell Checker Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE 3.0RC Review+ Cc:

Description

This issue can be checked with the SCAYT plugin enabled. The "More suggestions" option gets wrapped and hidden.

Confirmed with IE only for now.

Attachments (5)

IE7_Screenshot.png (25.8 KB) - added by Frederico Caldeira Knabben 10 years ago.
IE7 screenshot showing the issue
3766.patch (711 bytes) - added by Tobiasz Cudnik 10 years ago.
3766_2.patch (1.8 KB) - added by Tobiasz Cudnik 10 years ago.
3766_3.patch (2.3 KB) - added by Tobiasz Cudnik 10 years ago.
3766_4.patch (2.4 KB) - added by Tobiasz Cudnik 10 years ago.

Download all attachments as: .zip

Change History (16)

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: IE7_Screenshot.png added

IE7 screenshot showing the issue

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: 3.0RC added

comment:2 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3766.patch added

comment:3 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

It looks like the position:relative additions are not necessary. I've tested it with IE7 without it and things work well, in standards and quirks.

Also, I know that we haven't used much the .cke_kama selector in that file, but it's time to fix it. So, at least the new entries should have it.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3766_2.patch added

comment:5 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

Position relative is provided by body element, which is same width as context menu. Because of this it's practically not needed in .cke_label.

I'm attaching new patch which covers all skins.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The * .cke_skin_kama .cke_menuarrow selector is being accepted by all browsers. It looks like a clear solution would be introducing the CKEDITOR.env.cssClass value to the panel class.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3766_3.patch added

comment:7 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

Mentioned selector should be "* .cke_skin_kama_container .cke_menuarrow".

Third patch adds support for env.cssClass in panels and selectors are now using it.

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

It looks like this fix should apply to IE8+Quirks and IE8+Compat also. So, it makes sense having it for all IEs.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3766_4.patch added

comment:9 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

All IEs are now covered by this hack. One regression for IE8 quirks has been fixed also. All fixes were moved to more proper menu.css stylesheet.

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:11 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3740].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy