Opened 8 years ago

Closed 8 years ago

#3767 closed Bug (fixed)

IE: Second level menu may not have borders

Reported by: Frederico Caldeira Knabben Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Context Menu Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE 3.0RC Review+ Cc:

Description

In IE, the second level menus may be shown without border. The border appears as soon as we do some rollover in the menu (not always though).

This is a but random, but I'm able to constantly reproduce with the SCAYT plugin. It looks like a pure IE rendering bug. We should find a workaround for it.

Attachments (4)

IE7_Screenshot.png (28.8 KB) - added by Frederico Caldeira Knabben 8 years ago.
IE7 screenshot showing the issue
3767.patch (2.2 KB) - added by Tobiasz Cudnik 8 years ago.
3767_2.patch (681 bytes) - added by Tobiasz Cudnik 8 years ago.
3767_3.patch (731 bytes) - added by Tobiasz Cudnik 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by Frederico Caldeira Knabben

Attachment: IE7_Screenshot.png added

IE7 screenshot showing the issue

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: 3.0RC added

comment:2 Changed 8 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3767.patch added

comment:3 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

Holly hack! But it looks like something else ended up by mistake into the patch.

Also, can you improve the coding style a bit?

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3767_2.patch added

comment:5 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3767_3.patch added

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Please try the following option before committing:

panel.element.getChild( 0 ).$.style.cssText += '';

comment:7 Changed 8 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3739] using Frederico's suggestion.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy