Opened 10 years ago

Closed 7 years ago

#3784 closed Bug (duplicate)

[IE] Paragraph before table is not deleteable

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: Cc: monahant@…

Description

Reproducing Procedures

  1. Open the replace by class example page with IE6.
  2. Click on 'New Page' to clear up document;
  3. Insert a default table, then click the spaces before the table;
    • Exptected Result: You get a empty paragrahp created.
  4. Click on the created paragraph, press 'Backspace';
    • Exptected Result : The paragraph is deleted.
    • Actual Result : It's unable to delete the paragraph;

Change History (12)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: 3.0RC removed

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1CKEditor 3.2

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.3

comment:5 Changed 10 years ago by Garry Yao

Milestone: CKEditor 3.3CKEditor 3.4

Now table insertion in empty paragraph always replace it so the severity of this problem is much lower.

comment:6 Changed 9 years ago by brooks

Keywords: Confirmed added
Owner: set to brooks
Status: newassigned
Version: SVN (CKEditor)

confirmed in firefox3.5,IE8

comment:7 Changed 9 years ago by brooks

Owner: brooks deleted
Status: assignednew

comment:8 Changed 9 years ago by Garry Yao

The problem here in Firefox and IE should be distinguished:

  1. IE: A browser bug at first place, the first paragraph can't be removed by backspace or del.
  2. FF: After the paragraph is removed by the keystrokes, we fix the range with a block so it's looks as if it's never been removed.

The problem is that our fix body logic has no awareness of the reason how such a range (collapsed under body) is formed, as it's not a fault in some cases:

  1. When the cursor is moved there with navigation keys (e.g. Arrow keys) the current behavior is reasonable.
  2. When is rather left there because of modification keys (e.g. Del, Backspace), the cursor should be moved into surrounding blocks instead.

comment:9 Changed 9 years ago by Garry Yao

Milestone: CKEditor 3.4CKEditor 3.5

In any case, the fixing of this bug requires additional keystrokes handling, is what we're trying to avoid in this milestone, as those keystrokes are quite often used and may easily lead to regressions, we could handle this along with other keystroke management required bugs in next milestone.

comment:10 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.5

comment:11 Changed 7 years ago by Teresa Monahan

Cc: monahant@… added

comment:12 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

DUP of #6217

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy