Opened 10 years ago

Closed 10 years ago

#3796 closed Bug (fixed)

Anchors are not always editable

Reported by: Frederico Caldeira Knabben Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed 3.0RC Review+ Cc:

Description

  1. Load the following HTML:
<p><a name="Test" title="The Title"></a></p>
  1. Right click the anchor and select "Edit Anchor". (The "Name" field will be empty in the dialog)
  1. Type a new name, like "Changed".

In source view you will find the following, indicating that the element has been totally replaced:

<p><a name="Changed"></a></p>

Attachments (1)

3796.patch (2.3 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: 3.0RC added

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 10 years ago by Martin Kou

Attachment: 3796.patch added

comment:3 Changed 10 years ago by Martin Kou

Keywords: Review? added

This is a regression bug caused by changes to the selection/range system and then the _cke_saved_name attribute added in htmldataprocessor for <a> tags.

comment:4 Changed 10 years ago by Martin Kou

#3797 is marked as a dup of this ticket.

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:6 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3732].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy