Opened 13 years ago

Closed 13 years ago

#38 closed Bug (fixed)

The style combo doesn't update in Firefox like in IE

Reported by: Alfonso Martínez de Lizarrondo Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: FCKeditor 2.4
Component: General Version:
Keywords: Cc:

Description

This is due to this line:

	// For some reason Gecko is blocking inside the "RefreshVisibleItems" function.
	if ( ! FCKBrowserInfo.IsGecko )
		targetSpecialCombo.OnBeforeClick = this.RefreshVisibleItems ;

in FCKToolbarStyleCombo.prototype.CreateItems, but the fact is that only Firefox 1.0 seems to have this problem, so I've adjusted it in my branch to:

	// For some reason Gecko is blocking inside the "RefreshVisibleItems" function.
	// The problem is present only in old versions
	if ( !( FCKBrowserInfo.IsGecko && FCKBrowserInfo.IsGecko10 ) )
		targetSpecialCombo.OnBeforeClick = this.RefreshVisibleItems ;

Change History (2)

comment:1 Changed 13 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.4

If you had good results from your tests, just go ahead moving this one to the trunk.

The developments for the 2.5 will probably touch this one too, but it would be nice to have it working for the 2.4 too.

comment:2 Changed 13 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: newclosed

Since I changed this code one year ago I didn't have any problem. There are other adjustments to make the style combo work nice in Firefox, but those should be part of 2.5

merged in revision 61

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy