Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3846 closed Bug (fixed)

Google Chrome - No Img properties after inserting

Reported by: Scott Owned by: Minh Nguyen
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.0 RC
Keywords: Confirmed Chrome Safari Review- Cc:

Description

After inserting an image, image info does not appear in the dialog box.

Attachments (3)

3846.patch (6.6 KB) - added by Garry Yao 8 years ago.
3846_2.patch (1.5 KB) - added by Minh Nguyen 8 years ago.
3846_3.patch (1.6 KB) - added by Minh Nguyen 8 years ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 8 years ago by Garry Yao

Keywords: Pending added; img properties dialogs removed

Please provide more detail, what exactly properties have lost in dialogs?

comment:2 Changed 8 years ago by Scott

All properties go away. I used http://z.about.com/d/space/1/5/Y/Q/sun_tour.jpg, set the alternate text, border, hspace, vspace, and aligned left.

If I highlight the image, and choose image properties from either the toolbar or context menu, all of the properties are gone from the dialog box. All info is dropped from Image Info, Link, and Advanced tabs.

I'm on XP SP2. Google Chrome 2.0.172.33.

Sorry for the lack of detail. New to filing tickets. Let me know if I need to send anything else.

comment:3 Changed 8 years ago by Artur Formella

Keywords: WorksForMe added; Pending removed

I was unable to confirm this bug on Google Chrome 2.0 (Vista32).

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Component: UI : DialogsGeneral
Keywords: Confirmed WebKit added; WorksForMe removed

Confirmed, but not always. It looks like it depends on the image alignment. It's always reproducible by loading the following HTML:

<p>
	<img align="left" alt="" height="110" src="http://www.google.com/intl/en_ALL/images/logo.gif" width="276" />Test</p>

Just right click the image and open the Image Properties dialog.

Confirmed with Safari also.

comment:5 Changed 8 years ago by Alfonso Martínez de Lizarrondo

The 2.x version of this problem is #2570

I added there a TC to check this problem in V3, using that it might be possible to find a workaround (I had some ideas when I wrote it, but now I've already forgotten about the details)

comment:6 Changed 8 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

@alfonsoml: The TC helps[[BR]]

The problem is interesting, and I think we should blame our selection system, selection with range like following should be considered as element type:

<p><b>before[</b><img../><b>]after</b></p>

comment:7 Changed 8 years ago by Garry Yao

Keywords: Review? added

Changed 8 years ago by Garry Yao

Attachment: 3846.patch added

comment:8 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

This change is too risky at this stage. I'm delaying it to the next release.

comment:9 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review- added; Review? removed

I'm still experiencing this issue for any left or right aligned image on Chromium.

comment:10 Changed 8 years ago by Garry Yao

Owner: Garry Yao deleted
Status: assignednew

comment:11 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1CKEditor 3.2

If we're facing a browser bug, I think we should simply report it at WebKit for now, as the level of complexity for the fix (if any) is too high and risky.

comment:12 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.3

comment:13 Changed 8 years ago by kfancy

confirmed for CKEditor 3.0.1 + CKFinder 1.4.1.1, in Safari (webkit):

if align is set to left or right, then save the edit window, then right-click edit the image properties, all info disappears.

comment:14 Changed 8 years ago by Frederico Caldeira Knabben

#5001 has been marked as DUP.

Changed 8 years ago by Minh Nguyen

Attachment: 3846_2.patch added

comment:15 Changed 8 years ago by Minh Nguyen

Keywords: Review? added; Review- removed
Owner: set to Minh Nguyen
Status: newassigned

Changed 8 years ago by Minh Nguyen

Attachment: 3846_3.patch added

comment:16 in reply to:  15 Changed 8 years ago by Garry Yao

Keywords: Chrome Safari Review- added; WebKit Review? removed

Replying to m.nguyen: This new approach is a nice attempt, while we can't use selection locking here to resolve this problem, we should gain the lock only when focus is leaving the document, e.g. go to an dialog or context menu. In your patch, by gaining lock on a 'mousedown' event will cause subsequent selection manipulation invisible to users, proved by the following case:

Reproducing Procedures

  1. Load the document with the following contents:
     <p>
    	<img align="left" alt="" height="110" src="http://dev.fckeditor.net/chrome/site/logos.gif" width="276" />Test</p>
    
  2. Click on the image directly before focus the editor;
  • Expected Result: The image is selected.
  • Actual Result:The image is not highlighted, it takes another click to have it selected.

comment:17 Changed 8 years ago by Minh Nguyen

#5277 has been marked as DUP

comment:18 Changed 8 years ago by David Maggard

It appears this same bug occurs in Adobe Air

comment:19 Changed 8 years ago by Minh Nguyen

It works for me right now with trunk version, I think someone had fixed with other ticket.

comment:20 Changed 8 years ago by Alfonso Martínez de Lizarrondo

That ticket is #4830, so it just needs to be verified and add the changelog entry

comment:21 Changed 8 years ago by Minh Nguyen

Resolution: fixed
Status: assignedclosed

Was fixed with [5254] and [5255] and [5256] by Garry on ticket #4830.

comment:22 Changed 8 years ago by Minh Nguyen

and [5330].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy