Opened 10 years ago

Closed 10 years ago

#3866 closed Bug (worksforme)

Unable to run properly when js files retrieve from subdomain url

Reported by: xiaoyi Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: 3.0 RC
Keywords: Cc: zuyi.wang@…

Description

Hello,

Regarding ckeditor RC release, I have found an issue that the script Unable to run properly when js files retrieve from subdomain url

I am currently running two sites, both sites have exact same functions and codes.

#1 www.abc.com #2 www1.abc.com

I have done 3 tests

1, when a file within www.abc.com load ckeditor files from https://www.abc.com/fckeditor/ckeditor/ckeditor.js, the script executed correctly.

2, when a file within www1.abc.com load ckeditor files from https://www1.abc.com/fckeditor/ckeditor/ckeditor.js, the script cannot be executed.

3, when a file within www1.abc.com load ckeditor files from https://www.abc.com/fckeditor/ckeditor/ckeditor.js, the script executed correctly.

all the tests can lead a conclusion that JS files retrieved from subdomian site cannot be executed correctly.

Thanks

Zuyi

Change History (6)

comment:1 Changed 10 years ago by Tobiasz Cudnik

Keywords: CKEDITOR 3 subdomain removed
Priority: HighNormal
Resolution: invalid
Status: newclosed

This concerns only release's sample pages. That's because those pages use AJAX to be build and this creates permission issue when doing XHR request to other (sub)domain.

When testing normal page everything works fine (at least on FF3, IE8 and Chrome).

Please reopen this ticket if you have some more informations and affected are not only sample pages.

comment:2 Changed 10 years ago by xiaoyi

Resolution: invalid
Status: closedreopened

It is not only affect sample page,

for example

page: https://www1.abc.com/index.html loads https://www1.abc.com/fckeditor/ckeditor/ckeditor.js,

within index.html, I have following codes

<script type="text/javascript" src="https://www1.abc.com/fckeditor/ckeditor/ckeditor.js"></script>

. . . . <textarea name="description" cols="50" rows="10" id="description"></textarea> . . . <script type="text/javascript"> window.onload = function() {

CKEDITOR.replace( 'description' );

</script>

it doesn't work.

Thanks

Zuyi

comment:3 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: reopenednew

comment:4 Changed 10 years ago by Tobiasz Cudnik

Keywords: Pending added
Status: newassigned

I'm sorry but i'm still unable to reproduce this issue. I've done various tests on RC and trunk versions using SSL on 2 and 1 subdomains.

I need more informations:

  • Can you provide JS console error (if any) and browser name with version ?
  • Are you sure that the exact same files work without subdomain ?
  • Please try to request JS files directly to check that HTTP connection is all right.

Moreover, you can use some HTTP header dumper (like Firebug's net panel) to see whats up with the headers.

comment:5 in reply to:  4 Changed 10 years ago by xiaoyi

Hi,

After I re-download and sychronize both site's codes, this issue seems to be resolved. I will be keep monitoring, and will get back to you if any issue arised. Thanks Zuyi

Replying to tobiasz.cudnik:

I'm sorry but i'm still unable to reproduce this issue. I've done various tests on RC and trunk versions using SSL on 2 and 1 subdomains.

I need more informations:

  • Can you provide JS console error (if any) and browser name with version ?
  • Are you sure that the exact same files work without subdomain ?
  • Please try to request JS files directly to check that HTTP connection is all right.

Moreover, you can use some HTTP header dumper (like Firebug's net panel) to see whats up with the headers.

comment:6 Changed 10 years ago by Tobiasz Cudnik

Keywords: Pending removed
Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy