Opened 11 years ago

Closed 10 years ago

Last modified 4 years ago

#389 closed Bug (fixed)

Past from Word - error when text have "Comments"

Reported by: Zahar Chernov Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: Plugin : Paste from Word Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Cc:

Description

Reciving JS error message, on cleaner screen, when i'm pasting some text from Word that have Comment inside.
It happens on my system and on fck demo and night build.

Scenario:
1) Open Word
2) Write some text (even 2 word's is ok)
3) mark one of words and add comment on it
4) Past text from Word to FCKEditor
KO: when you move mouse after CTRL+V, JS error jump. (error line different depends on line num)

Change History (7)

comment:1 in reply to:  description Changed 11 years ago by Zahar Chernov

I just noticed that JS Error popup just when you move mouse over comment "block" inside cleaner window.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added; Past from Word removed
Version: SVN

Confirmed with IE6. No problem with FF2.

The problem is that IE is getting a lot of JavaScript from Word, which get "active" inside the editor, making references to invalid functions.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

This could be done with the proposal in #1055

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6FCKeditor 2.5
Resolution: fixed
Status: assignedclosed

Fixed with [908]

I've left the code working for all browsers (I didn't specify only IE), but Opera doesn't paste HTML, just plain text (there's a bug about it), and Safari doesn't support window.onerror http://bugs.webkit.org/show_bug.cgi?id=8519, but it does try to execute the javascript in that area (not sure if it's reported) and the errors appear in the JS console.

At the same time, I've focused the area on load and fixed some problems that appeared while testing the dialog.

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Safari executing the events in a designMode document is http://bugs.webkit.org/show_bug.cgi?id=15316, and Opera tracks the same problem in Opera bug 272216

comment:7 Changed 4 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy