Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#388 closed Bug (fixed)

MSIE Problem: Linking two lines in a list

Reported by: Patrick Hagemeister Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: FCKeditor 2.4.3
Component: General Version:
Keywords: Cc:

Description

One of our customers just found a problem with FCKEditor. He's putting quite a lot of pressure on us to get it fixed, so if you could take a look and advise what we can do about it...

Abstract

There is a Problem in FCKEditor when using MSIE 6 (and possibly also 7, not tested). If you have two lines separated by a <br/> tag in a single <li> List Element and try to link these two lines to a different location, the editor links both lines to the same location.

How to reproduce

  1. Open http://www.fckeditor.net/demo
  2. Delete all text
  3. Insert a numbered List and write:
    This is line A[Shift-Return]This is line B

    This should produce this piece of HTML:
    <ol>
        <li>This is line A<br />
        This is line B</li>
    </ol>
    
  4. Mark the first line ("This is line A") and link it to some URL, i.e. "http://www.google.com"
  5. Mark the second line ("This is line B") and link it to some URL, i.e. "http://www.fckeditor.net"
  6. The editor now extends the marked range *and* the link to both lines automatically, so both lines are linked to the second URL (i.e. "http://www.fckeditor.net")

Demonstration Video/Screencast

http://sp-web-01.krankikom.de/~wwwadmin/FCKEditor_bug_linklistlines/FCKEditor_bug_linklistlines.html

If you need any more info, please let me know... (also via Phone if you want: +49-203-30597-54).

Best Regards, Patrick

Change History (7)

comment:1 Changed 11 years ago by Patrick Hagemeister

Hi, first feedback from Frederico Caldeira Knabben (via email support request) was:

QUOTE

Thanks for your details report. The screencast helped a lot to understand the problem, as I was not able to reproduce it promptly.

This problem will only happen if you select "This is line A", dragging the mouse far from the right side of "A". It actually selects the line break too. If you stop the tests with only the first link, this is what you will have:

<ul>
    <li><a href="http://A">This is line A<br />
    </a>This is line B</li>
</ul>

As you can see, the <br /> is part of the link. So, when selecting "This is line B", part of the previous <a> gets somehow selected too (I'm trying to explain what I believe IE does internally).

You will not have the same problem if you make the selection finishing precisely at "A". That would be a temporary way to avoid the problem.

Also, it not only happens inside a <li>. It will happen anywhere you have a <br>.

comment:2 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

With the description from Frederico it should be easy to fix this problem: if the last node of a link is a <br> then move it out of the link.

I'm gonna test it now.

comment:3 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: assignedclosed

Fixed in [252]

comment:4 Changed 11 years ago by Patrick Hagemeister

Resolution: fixed
Status: closedreopened

Thanks very much!

You linked the fix to the wrong ticket in whatsnew.html though (ticket:338 instead of ticket:388): changeset:252 Don't know whether it's worth fixing...

Best Regards, Patrick

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: reopenedclosed

Fixed the link with [254]. Thanks for the detail Patrick, and many thanks to Alfonso for the fix.

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5FCKeditor 2.4.3
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy