Opened 10 years ago

Closed 10 years ago

#4003 closed Bug (fixed)

Markup on the image dialog disrupted when removing the border input

Reported by: Sa'ar Zac Elias Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IE Confirmed Review+ Cc:

Description

When removing the border option, the whole dialog markup is disrupted (on IE). It only happens if the language uses RTL direction. http://i27.tinypic.com/110ka43.png

Attachments (2)

replacebycode.html (2.3 KB) - added by Frederico Caldeira Knabben 10 years ago.
Test Case
4003.patch (1.4 KB) - added by Tobiasz Cudnik 10 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Which IE version precisely?

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Also... do you have this issue with the Kama skin?

comment:3 Changed 10 years ago by Sa'ar Zac Elias

Right now i'm using IE8 but it also happend on IE7. And no, i'm not having this issue with the Kama skin.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0

We'll be checking it.

comment:5 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

comment:6 Changed 10 years ago by Tobiasz Cudnik

Keywords: IE Pending added

Sorry, but can't reproduce it.

I've checked office2003 skin in quirks and strict mode using Arabic language. I've set border value, it got applied on preview, then removed it and nothing has changed in dialog layout.

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added; Pending removed

It looks like it happens if the connection is not that fast, so the dialog takes time to load and build.

I'm able to reproduce it with a clean cache, when loading the ckeditor.js file from the nightly build.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: replacebycode.html added

Test Case

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

I'm able to reproduce it with the file I've just attached to this ticket. It happens always with a clean cache and IE7.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 4003.patch added

comment:9 Changed 10 years ago by Tobiasz Cudnik

This patch double checks dialog size to ensure that borders are correct.

We can extract references to elements outside function to avoid double creations.

comment:10 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added

comment:11 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Ok... that's ugly though... anyway, let's do this way and then wait for the feedback.

comment:12 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3983].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy