Opened 10 years ago

Closed 10 years ago

#4068 closed Bug (worksforme)

Nested numbered list issue

Reported by: Damian Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: SVN (CKEditor) - OLD
Keywords: IBM Pending Cc:

Description

  1. Open nightly Ajax sample.
  2. Go to source mode and paste the following numbered list
    <ol>
    	<li>
    		Line one</li>
    	<li>
    		Line two
    		<ol>
    			<li>
    				This is submenu 1</li>
    			<li>
    				This is submenu 2</li>
    			<li>
    				This is submenu 3</li>
    			<li>
    				This is submenu 4</li>
    			<li>
    				This is submenu 5</li>
    		</ol>
    	</li>
    </ol>
    
  3. Place cursor at the end of line "submenu 5"
  4. Hit Enter
  5. At this point you should have an empty 6. number line.
  6. Hit Enter again.
  7. The list continues from the first level. Sometimes this will start from 1. or it may continue and show 3.
  8. Hit Enter again
  9. Now the result is:
    <ol>
    	<li>
    		Line one</li>
    </ol>
    <p>
    	Line two</p>
    <ol>
    	<li>
    		This is submenu 1</li>
    	<li>
    		This is submenu 2</li>
    	<li>
    		This is submenu 3</li>
    	<li>
    		This is submenu 4</li>
    	<li>
    		This is submenu 5</li>
    	<li>
    		&nbsp;</li>
    </ol>
    

This very different from the expected behaviour. Reproduced on IE7 and FF3.

Change History (3)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Lists
Milestone: CKEditor 3.xCKEditor 3.1
Version: SVN (CKEditor)

comment:2 Changed 10 years ago by Tobiasz Cudnik

Keywords: Pending added

Seems to be fixed with one of many list related tickets for final 3.0 milestone.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1
Resolution: worksforme
Status: newclosed

WFM also.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy