Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4067 closed New Feature (fixed)

Fullpage support

Reported by: Garry Yao Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.1
Component: Core : Output Data Version:
Keywords: Confirmed Review+ Cc:

Description

The editor don't actually have full page support yet despite of the existence of fullPage config entry.

Attachments (4)

4067.patch (20.7 KB) - added by Garry Yao 10 years ago.
4067_2.patch (21.5 KB) - added by Garry Yao 10 years ago.
4067_3.patch (23.1 KB) - added by Garry Yao 10 years ago.
4067_4.patch (26.9 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Component: Core : Output DataGeneral
Keywords: Confirmed added
Milestone: CKEditor 3.0CKEditor 3.1

This setting is still not active.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Type: BugNew Feature

comment:3 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: 4067.patch added

comment:4 Changed 10 years ago by Garry Yao

Component: GeneralCore : Output Data
Keywords: Review? added

Please note that I'll open new ticket for full page support in preview plugin as well as document property dialog, this ticket has dedicated to data I/O features.

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review- added; Review? removed
  1. Filter rules related to design mode should be moved into 'wysiwyg' plugin
  2. 'toHtml/toDataFormat' should be editor ignorant.

Changed 10 years ago by Garry Yao

Attachment: 4067_2.patch added

comment:7 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

Let's try making this solution a bit simpler. It would be also nice to have it as a separate plugin.

Changed 10 years ago by Garry Yao

Attachment: 4067_3.patch added

comment:9 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

Move around 200 LOC into a dedicated 'fullpage' plugin make changes to the core much smaller.

comment:10 in reply to:  9 Changed 10 years ago by Piotr Szczap

Replying to garry.yao:

Move around 200 LOC into a dedicated 'fullpage' plugin make changes to the core much smaller.

Patched the HEAD revision today with 4067_3.patch. It works, except that the editor does not load stylesheets in the <head> section (both <link rel="stylesheet" ... > and <style>...</style>).

There also seems to be a problem if the entered markup contains anything before the opening <html> tag (eg. comments, <!doctype). CKeditor fails to detect the opening <html> tag and puts everything in its own <html> and <body> tags in such case.

comment:11 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
  • Typo in the wysiwyg area plugin line 18 (:?) instead of (?:).
  • Please fix the spelling from $noneBodyContent to $nonBodyContent.
  • We don't need an additional docType method in the basicWriter. The "write" method can be used for that.
  • The fragment in fact should not really care if the document is full page or not. It must simply parse any HTML. The data processor should take care of the differences instead.
  • In the wysiwyg plugin, in getData, editor.config.fullPage can be cached in a local var.
  • Always in getData, there is some additional processing that's always happening, even if fullPage == false. The documentElement and docTypeAttr values are being calculated even if not needed.
  • The shelveTags can be more generic use. It can be also split with the unshelveTags.
  • The doctype should be handled into the fullpage plugin actually. We must try concentrating all full page stuff there.

Changed 10 years ago by Garry Yao

Attachment: 4067_4.patch added

comment:12 Changed 10 years ago by Garry Yao

Ticket test updated.

comment:13 Changed 10 years ago by captwheeler

Checked out SVN and built it, but still not submitting the whole page. There is a DOCTYPE on the page. config.fullPage = true; is in the config. I'll try the nightly tomorrow.

comment:14 Changed 10 years ago by captwheeler

Nightly build 4536 didn't work. Thanks for working on this.

comment:15 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignednew

I've opened a feature branch for this feature:
http://svn.fckeditor.net/CKEditor/branches/features/fullpage/

comment:16 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

Ticket TCs updated.

comment:17 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [4636].

comment:18 Changed 10 years ago by Frederico Caldeira Knabben

#4769 has been marked as DUP.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy