Opened 10 years ago

Closed 10 years ago

#4078 closed Bug (fixed)

[IE7] v2 skin has empty group

Reported by: Garry Yao Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Toolbar Version:
Keywords: IE7 Confirmed Review+ Cc:

Description

An empty group appear at the front of the second row in toolbar with full-buttons mode.

Attachments (4)

IE7.png (6.9 KB) - added by Garry Yao 10 years ago.
Screenshot of IE7
IE7_en.png (15.4 KB) - added by Garry Yao 10 years ago.
Screenshot of IE7 with English language
4078.patch (2.1 KB) - added by Garry Yao 10 years ago.
4078_2.patch (1.2 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (16)

Changed 10 years ago by Garry Yao

Attachment: IE7.png added

Screenshot of IE7

comment:1 Changed 10 years ago by Tobiasz Cudnik

WorksForMe. Reason isn't an empty group, but incorrect wrapping. They have been seen in the past, but were fixed.

Have you done something special to get this effect ? I've used resize handler and it wrapped correctly on both strict and quirks.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

It may be that the Chinese text makes it happen.

comment:3 Changed 10 years ago by Tobiasz Cudnik

Keywords: Confirmed added

Confirming with "zh-cn" language.

comment:4 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

comment:5 Changed 10 years ago by Garry Yao

The problem is affecting all Asia language and in certain case it's breaking Latin language either.

Changed 10 years ago by Garry Yao

Attachment: IE7_en.png added

Screenshot of IE7 with English language

comment:6 Changed 10 years ago by Garry Yao

Keywords: Discussion added
Owner: Garry Yao deleted
Status: assignednew

I've been tried various way but resulting in the only way for eliminate this problem is by removing the default 'font-size' rule from L30 of reset.css, which seems not acceptable, call for discussion.

comment:7 Changed 10 years ago by Tobiasz Cudnik

Maybe we should have dedicated font-size per language ?

Changed 10 years ago by Garry Yao

Attachment: 4078.patch added

comment:8 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

Proposing a solution which apply the reset font size only in a text-oriented manner.

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Discussion Review? removed
Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignednew

I would avoid drastic changes at this point. I'm coming with a simpler patch for it.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 4078_2.patch added

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Status: newassigned

comment:11 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:12 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3988].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy