Opened 8 years ago

Closed 8 years ago

#4084 closed Bug (fixed)

[FF] Image dialog using Kama skin sticks to left viewport border

Reported by: Tobiasz Cudnik Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Firefox Confirmed Review+ Cc:

Description (last modified by Tobiasz Cudnik)

In Firefox (3, 3.5) using Kama skin, after opening image dialog it sticks to left viewport border. Drag&drop it to the right is impossible.

Quirks mode only, on pages with 3 editors, each with different skin.

Attachments (4)

ltr_quirks.html (1.8 KB) - added by Tobiasz Cudnik 8 years ago.
Test page.
4084.patch (1.1 KB) - added by Tobiasz Cudnik 8 years ago.
4084_2.patch (2.3 KB) - added by Tobiasz Cudnik 8 years ago.
4084_3.patch (1.4 KB) - added by Tobiasz Cudnik 8 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 8 years ago by Tobiasz Cudnik

Keywords: Confirmed added
Owner: set to Tobiasz Cudnik
Status: newassigned

comment:2 Changed 8 years ago by Tobiasz Cudnik

Description: modified (diff)

Changed 8 years ago by Tobiasz Cudnik

Attachment: ltr_quirks.html added

Test page.

comment:3 Changed 8 years ago by Tobiasz Cudnik

Dialogs size is incorrectly read during initial creation. Later it's ok, but old value remains inside dialog system.

Seems to be caused by "lock ratio" and "reset size" buttons (removing them resolves the issue).

Random.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 4084.patch added

comment:4 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added

Longer timeout seems to resolve this issue, although it may still exists on slower machines.

I think that dialog system should contain onLoad event, which would be the safe start for all dialog manipulation functions.

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

Ideally we should have no delay at all there. Having 100ms is not the best thing, but acceptable. But now 500ms is definitely too much and decisivelly noticeable.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 4084_2.patch added

comment:6 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

It seems we can use definition size with success for initial position, as actual dialog layout is fixed. Doing such, we can completely loose timeout and prevent this issue.

#4095 looks like a DUP of this ticket.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 4084_3.patch added

comment:7 Changed 8 years ago by Tobiasz Cudnik

Previous patch suffered from height problem, as definition size defines dialog contents size, not whole dialog (title & footer).

Third patch uses height from offsetHeight and width from definition. Unfortunately previous timeout of 100ms is still needed.

comment:8 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:9 Changed 8 years ago by Tobiasz Cudnik

Fixed with [3976].

comment:10 Changed 8 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy