Opened 8 years ago

Closed 8 years ago

#4096 closed Bug (fixed)

Editor content area pushed down in RTL quirks

Reported by: Tobiasz Cudnik Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IE Confirmed Review+ Cc:

Description

Editor content area pushed down in RTL quirks. All IEs affected. Attaching screenshot.

Attachments (4)

2009-07-24-102150_539x95_scrot.png (4.9 KB) - added by Tobiasz Cudnik 8 years ago.
4096.patch (1.2 KB) - added by Tobiasz Cudnik 8 years ago.
4096_2.patch (1.3 KB) - added by Tobiasz Cudnik 8 years ago.
4096_3.patch (1.3 KB) - added by Tobiasz Cudnik 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by Tobiasz Cudnik

comment:1 Changed 8 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

comment:2 Changed 8 years ago by Garry Yao

Confirmed on all skins except Kama.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 4096.patch added

comment:3 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

There is still a 1px space being left there.

I had better results by setting position:absolute, instead of changing font-size.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 4096_2.patch added

comment:5 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

You're right. In second patch i've used position absolute and targeted this hack only for [IE, quirks, RTL].

I've done some tests with nesting editor inside scrollable area and it seems no problems caused by this change.

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

I was able to reproduce it in IE+LTR+Quirks also. I've then remove the RTL check from the patch and it fix it also. I've tested it with all browsers and it looks good, so I think we could do it on LTR safely.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 4096_3.patch added

comment:7 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

comment:8 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:9 Changed 8 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3984].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy