Opened 6 years ago

Closed 6 years ago

#4100 closed Bug (fixed)

[IE] Navigation keyset has no effect with panel

Reported by: garry.yao Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: Accessibility Version:
Keywords: IE Confirmed Review+ Cc:

Description

Reproducing Procedures

  1. Open the 'replace by class' sample page in IE;
  2. Click on 'Format' combo to open drop down panel;
  3. Press 'Arrow Down' to navigate to the next panel item;
    • Actual Result: The keystroke has no effect.

Attachments (2)

4100.patch (1.2 KB) - added by garry.yao 6 years ago.
4100_2.patch (2.0 KB) - added by tobiasz.cudnik 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by garry.yao

comment:1 Changed 6 years ago by garry.yao

  • Keywords Confirmed Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

comment:2 Changed 6 years ago by tobiasz.cudnik

  • Keywords Review- added; Review? removed

This ticket is a regression caused by [3963] from #3946.

Proposed patch causes regression against #3946. Second level context menu could not be hidden in specific situation.

comment:3 Changed 6 years ago by tobiasz.cudnik

  • Keywords Review? added; Review- removed

This patch simulates missing focus event handler (for context menu) while the real focus is triggered for iframe (for navigation).

Focus logic is reverted to that one from before [3963].

Changed 6 years ago by tobiasz.cudnik

comment:4 Changed 6 years ago by tobiasz.cudnik

  • Owner changed from garry.yao to tobiasz.cudnik
  • Status changed from assigned to new

After discussing it with Frederico i'm taking over this ticket.

comment:5 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:6 Changed 6 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [3972].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy