Opened 10 years ago

Closed 8 years ago

#4131 closed New Feature (invalid)

Add Button Media to insert tag [[Media:mediafile.pdf mediafile]]

Reported by: kat Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.4
Keywords: Cc:

Description (last modified by Frederico Caldeira Knabben)

In our wiki we add a lot of Word documents, PDF files and other media files. We use the Image Button in order to insert these, but this causes the link to not open directly but through a second step in MediaWiki. The proper tag for documents and media is the [[Media:xxxx.xxx name]] tag.

Please add a checkmark or a radio button in the Insert Image (Image Properties) dialog box to change between the [[Image: tag and the [[Media: tag. Or add it to the Dropdown Special Type

Steps to reproduce:

  • Upload a PDF, DOC, ODT, ect. to MediaWiki through File Upload
  • Start FCKEditor
  • Click on the Insert Image button on the toolbar
  • Type in the name of the file you uploaded in the 1st step
  • Click on the name found in the Automatic Search Results
  • Fill in a caption
  • Click OK
  • Click on Wikitext (you see the [[Image:xxxx.xxx caption]] tag.
  • Click on Wikitext again and save the page
  • You then get a list of everything that was done to the file and have to click a second time to open the file
  • Edit the page again but change in wikitext the [[Image:xxxx.xxx]] to [[Media:xxxx.xxx]]
  • Save the page
  • Now click on the link again... the document opens in one click.

Change History (2)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Documents Media Insert Media removed
Milestone: FCKeditor 2.6.5

comment:2 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy