Ticket #4188 (closed Bug: fixed)

Opened 5 years ago

Last modified 4 years ago

Tab key on Paste dialog incorrect

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Dialogs Version:
Keywords: IE Safari Confirmed Cc:

Description

It's not able to move focus to dialog buttons by tab key in Paste dialog.

Reproducing Environment

  • IE6/Safari4

Attachments

4188.patch (535 bytes) - added by garry.yao 5 years ago.

Change History

comment:1 Changed 5 years ago by fredck

  • Milestone changed from CKEditor 3.0 to CKEditor 3.1

Changed 5 years ago by garry.yao

comment:2 Changed 5 years ago by garry.yao

  • Status changed from new to assigned
  • Owner set to garry.yao

comment:3 Changed 5 years ago by garry.yao

  • Keywords Review? added

comment:4 Changed 5 years ago by garry.yao

  • Keywords Review- added; Review? removed

Doesn't work in IE6/7 due to a browser bug even after the patch.
Browser TC added at : http://ckeditor.t/bt/remove_focus_from_editable_iframe/1.html

comment:5 Changed 5 years ago by garry.yao

  • Keywords Discussion added

The only workaround I can see here is to turn off the design mode while moving the focus.

comment:6 Changed 4 years ago by fredck

  • Milestone changed from CKEditor 3.1 to CKEditor 3.2

comment:7 Changed 4 years ago by fredck

  • Milestone changed from CKEditor 3.2 to CKEditor 3.3

comment:8 Changed 4 years ago by garry.yao

Supposed to be fixed by [4957] on aria branch.

comment:9 Changed 4 years ago by garry.yao

  • Keywords Review- Discussion removed

Now this ticket is supposed to be fixed by #5461.

comment:10 Changed 4 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy