Opened 8 years ago

Closed 8 years ago

#5461 closed Bug (fixed)

IE: Paste from Word dialog doesn't accept imput

Reported by: Frederico Caldeira Knabben Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Dialogs Version: 3.2
Keywords: confirmed Review+ Cc: satya_minnekanti@…

Description

Confirmed with IE8 and CKEditor 3.2. Works well with the 3.1.1.

  1. Open the Paste from Word dialog.
  1. Click on the bottom part of the pasting area. The caret will disappear.
  1. Try putting the caret back to the pasting area by mouse click. It's impossible.

Attachments (5)

5461.patch (792 bytes) - added by brooks 8 years ago.
5461_2.patch (1.1 KB) - added by brooks 8 years ago.
5461_3.patch (2.5 KB) - added by Garry Yao 8 years ago.
5461_4.patch (2.5 KB) - added by brooks 8 years ago.
5461_5.patch (697 bytes) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:2 Changed 8 years ago by brooks

IE6,winxp confirmed

comment:3 Changed 8 years ago by brooks

Owner: set to brooks
Status: newassigned

Changed 8 years ago by brooks

Attachment: 5461.patch added

comment:4 Changed 8 years ago by brooks

Keywords: Review? added; Confirmed removed

I don't know what's the purpose of http://dev.fckeditor.net/browser/CKEditor/trunk/_source/plugins/clipboard/dialogs/paste.js#L22
may be we can delete L22~L25
but right now I just want to make the iframe editable again.

comment:5 Changed 8 years ago by Garry Yao

Keywords: Review- added; Review? removed

This's a regression of [4957] because of #4188, but later we figured out better way to workaround this bug at #4716, which means something similar with [5311] should present here right now.

Changed 8 years ago by brooks

Attachment: 5461_2.patch added

comment:6 Changed 8 years ago by brooks

Keywords: Review? added; Review- removed

comment:7 Changed 8 years ago by Garry Yao

Keywords: Review- added; Review? removed

With IE8, it's now unable to have the cursor blinking anymore when using Tab Key to navigate to the paste area.
Besides, the bookmark looks unnecessary, generally user will just use the document as a paste bin.

Changed 8 years ago by Garry Yao

Attachment: 5461_3.patch added

comment:8 Changed 8 years ago by Garry Yao

Component: GeneralUI : Dialogs
Keywords: Confirmed Review? added; Review- removed

comment:9 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

There are two variables, "selection" and "bookmarks", which are being defined at line 15 but never used.

Changed 8 years ago by brooks

Attachment: 5461_4.patch added

comment:10 Changed 8 years ago by brooks

Keywords: Review? added; Confirmed Review- removed

comment:11 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:12 Changed 8 years ago by brooks

Keywords: confirmed added
Owner: changed from brooks to Garry Yao
Status: assignednew

fixed with 5483 5483

comment:13 Changed 8 years ago by brooks

Resolution: fixed
Status: newclosed

comment:14 Changed 8 years ago by Satya Minnekanti

Resolution: fixed
Status: closedreopened

This is still reproducible using IE7 on the nightly build.I could not put the cursor back in to the Pasting area using mouse.

Changed 8 years ago by Garry Yao

Attachment: 5461_5.patch added

comment:15 in reply to:  14 Changed 8 years ago by Garry Yao

Keywords: Review? added; Review+ removed

Replying to satya:

I could not put the cursor back in to the Pasting area using mouse.

The current issue for me is "only the first line is clickable to start edit", we could safely use quirks on the paste area to void this issue.

comment:16 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:17 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: reopenedclosed

Fixed with [5508].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy