Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#4716 closed Bug (fixed)

[IE7] Cursor remains in editor when you tab to following form button.

Reported by: Joe Kavanagh Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.0.1
Keywords: IBM Confirmed IE Review+ Cc: dchojna@…, philip_andrew@…

Description (last modified by Frederico Caldeira Knabben)

If the editor is the last component in a form and you tab out to apply focus to a button the cursor remains visible. If you enter text it will go into the editor at the cursor. If you press Enter the button, which has focus, will be pressed.

Insert an input field after the editor and before the button. Tab from the editor to the input field. The cursor is moved from the editor to the input field as normal.

Attachments (3)

4716.patch (663 bytes) - added by Garry Yao 10 years ago.
4716_2.patch (715 bytes) - added by Garry Yao 10 years ago.
4716_3.patch (838 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Milestone: CKEditor 3.1

I

comment:2 Changed 10 years ago by Garry Yao

Keywords: Confirmed added

Nice catch, have the same IE bug behind with #4188.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2

comment:4 Changed 10 years ago by Garry Yao

Keywords: IE added
Owner: set to Garry Yao
Status: newassigned

The problem only affects IE7.

Changed 10 years ago by Garry Yao

Attachment: 4716.patch added

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review? added

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

The patch is working fine for IE7, but I can reproduce the problem also in IE6 with the replacebyclass sample

Changed 10 years ago by Garry Yao

Attachment: 4716_2.patch added

comment:7 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

Reproduced on IE6 standard also.

comment:8 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:9 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5033].

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.3
Resolution: fixed
Status: closedreopened

I've just revered [5033] because of #5203. It looks like selection manipulation cannot be used to fix this one.

Please note that [5100] has been reverted as well.

comment:11 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review+ removed

Btw, reverted with [5162] and [5164].

Changed 10 years ago by Garry Yao

Attachment: 4716_3.patch added

comment:12 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:13 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:14 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review+ removed

What about putting the "if" before the listener, so the rest of the browsers ignore it?

comment:15 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review- removed
Resolution: fixed
Status: reopenedclosed

Fixed with [5310] and [5311].

comment:16 Changed 9 years ago by phil

Cc: philip_andrew@… added

Please see #5581.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy