Opened 7 years ago

Closed 7 years ago

#5462 closed Bug (expired)

Color is removed improperly from partial selections

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.3
Component: Core : Styles Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

  1. Open the replacebyclass sample.
  1. Hit CTRL+A to select all text.
  1. Apply a background color (e.g. yellow).
  1. Select "some sample".
  1. Apply a different background color (e.g. green).

The yellow background from the " text" bold text will be removed, remaining transparent.

Confirmed with FF 3.6 at least. Works well with the 3.2.

Attachments (2)

5462.patch (1.6 KB) - added by Garry Yao 7 years ago.
5462_2.patch (2.2 KB) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

As expected, the same happens with the foreground color.

comment:2 Changed 7 years ago by Garry Yao

Keywords: Firefox Safari added

Works in IE only.

Changed 7 years ago by Garry Yao

Attachment: 5462.patch added

comment:3 Changed 7 years ago by Garry Yao

Keywords: Review? added; Firefox Safari removed
Owner: set to Garry Yao
Status: newassigned

Oops, affects IE also.
Regression of [5251].

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignednew

The change makes sense, even if it still doesn't fix the partial override issue, which must not be handled by this ticket anyway.

I'll be providing a simplified patch.

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 5462_2.patch added

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Status: newassigned

comment:6 Changed 7 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:7 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5343].

comment:8 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: closedreopened

Due to the risky explained here, this fix is reverted by [5347] and the ticket is expired.

comment:9 Changed 7 years ago by Garry Yao

Resolution: expired
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy