Opened 10 years ago

Closed 10 years ago

#4197 closed Bug (fixed)

[Safari] format combo don't hide when editor blur

Reported by: Garry Yao Owned by: Minh Nguyen
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Floating Panel Version: SVN (CKEditor) - OLD
Keywords: Safari Confirmed Review+ Cc:

Description (last modified by Garry Yao)

Reproducing Procedures

  1. Open the 'replace by class' sample page in Safari;
  2. Open the 'Format' Combo, then click outside editor chrome;
    • Actual Result: combo panel won't able to hide from now on;

Attachments (2)

4197.patch (618 bytes) - added by Minh Nguyen 10 years ago.
With Safari and Chorme the 'elementPath' allways miss 'lastElement' object
4197_2.patch (452 bytes) - added by Minh Nguyen 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1
Priority: HighNormal

It's possible to close the combo by clicking on it again, at least.

comment:2 Changed 10 years ago by Garry Yao

Summary: [Safari] Float panel don't hide when editor blur[Safari] format combo don't hide when editor blur

The problem happens to 'Format' Combo specifically, modify summary.

comment:3 Changed 10 years ago by Garry Yao

Description: modified (diff)
Version: SVN (CKEditor)

Tidied description a bit.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1CKEditor 3.2

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.3

comment:6 Changed 10 years ago by Garry Yao

Even worse, 'Format' combo will not open at all on first click (without focus editor).

Changed 10 years ago by Minh Nguyen

Attachment: 4197.patch added

With Safari and Chorme the 'elementPath' allways miss 'lastElement' object

comment:7 Changed 10 years ago by Minh Nguyen

Keywords: Review? added
Owner: set to Minh Nguyen
Status: newassigned

comment:8 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

First of all, I've tried to reproduce the bug with Safari on windows but it behaved correctly.

The patch addresses the current ticket, but why isn't lastElement available in elementPath? other code might face this same problem so it might be worth to look at the problem at its root.

Also, I understand that this problem wasn't generating an error in the console, so if there's a try catch in the code that calls this, maybe it should be disabled (at least in _source mode) to find more easily this problems, or use the catch an ignore only expected failures.

Changed 10 years ago by Minh Nguyen

Attachment: 4197_2.patch added

comment:9 Changed 10 years ago by Minh Nguyen

Keywords: Review? added; Review- removed

When we click directly in 'Format' Combo (not focus editor), we will have an error. This bug happens (in Chorme and Safari) because the line code selection.getStartElement() http://dev.fckeditor.net/browser/CKEditor/trunk/_source/plugins/stylescombo/plugin.js#L157 returns null. This also happens in IE but we have already fixed by setting editor focus before getting selection.

comment:10 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:11 Changed 10 years ago by Minh Nguyen

Resolution: fixed
Status: assignedclosed

Fixed with [5318].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy