Opened 10 years ago

Closed 10 years ago

#4198 closed Bug (duplicate)

Problem with edited select - browser closes- IE and firefox

Reported by: Leandro Cardoso Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.4
Keywords: Confirmed IE Cc:

Description

Hi,

When i create a select component, edit it afterwards, and close the page where the fckeditor is. the browser freezes and i have to terminate it in order to keep working, sometimes i even have to reboot the machine, this error only comes up when i edit a select (combo box) and close the window..

Any ideas that might help??

version 2.6.4 Build 21629

Change History (8)

comment:1 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added; edit select browser freezes removed

Can you provide exact steps to reproduce the problem?

For example a test page with the required configuration and initial values and the steps that must be done to get the hang of the browser

comment:2 Changed 10 years ago by Leandro Cardoso

1-Create a component (Select/hidden/textBox/textArea..) 2-Right click on the component. 3-After you alter the component, and close the window. A window pops up saying that the ie of firefox had an unknown problem and needed to be closed. 4-If i alter the component using the source code, the error doesnt appear.

it's that basic.

IE version 6.0.2900.2180

Firefox version 3.5.1

Tried other versions of IE too, on the 7.0.6001 the error doesn't happen. The fckeditor is loaded into a Iframe, we use TIBCO General Interface as our RIA framework, so the iframe is inside a GUI dialog component, and when we close that dialog the error shows up.

Thanks in advance. Best, Leandro

comment:3 Changed 10 years ago by Alfonso Martínez de Lizarrondo

But where is the test page?

I can't reproduce it with the current demo: http://www.fckeditor.net/demo

Or do you expect us to install that "TIBCO General Interface" in order to test this problem?

BTW, if you have a crash in Firefox, I guess that you have sent the crash info to Mozilla. Can you check in about:crashes the ID of the event?

comment:4 Changed 10 years ago by Leandro Cardoso

Of course i don't expect you to do that..

I just thought that the more information i gave you, the easiest it would be to figure out the problem, i get "send a report problem" on the IE, firefox all it does is freeze.

If i somehow give you access to our system, to the part where that error happens, would it help??

Thanks in advance. Leandro

comment:5 Changed 10 years ago by Leandro Cardoso

hey i mounted a little app in Tibco so that you can reproduce the error, Just do as the instrauctions i gave you before and you'll be able to reproduce the error, i couldn't reproduce on your demo version because it only happens when the inside dialog of the tibco interface is closed. A huge part of our application is based on FckEditor, so we really need this to work, i really appreceate your help.

Thanks

Here is the link for the app

http://www.sendspace.com/file/amdoan

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Confirmed IE added; Pending removed

I've tested and it's working fine with Firefox 2 and 3.5, also with IE 6 and IE8, but in IE7 I get a crash in mshtmled.dll

I can crash it also if I create a table and then select it, or if I insert an image and select it.

So: if I close the "mini window" while the resizing handles are shown in any element, IE crashes.

I guess that this has the same root problem that #2201

But: as I said this is happening to me only in IE, I haven't noticed any problem with Firefox and I can't find any other bug about crashes or hangs with Firefox.

comment:7 Changed 10 years ago by Leandro Cardoso

hey,

I wasn't the one who tested it with firefox, and i just checked with the guy,and i noticed that he is using IE tabs on firefox, so the problem only happens on IE, sorry for that.

I read the ticket you mentioned, it seems like we have the same problem.

So it only happens on the IE browser, I can't debug or anything to even get close to the root problem, so i need your help on this one.

Thanks again.. Best, Leandro

comment:8 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Resolution: duplicate
Status: newclosed

So marking as dup of #2201

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy