Opened 10 years ago

Closed 10 years ago

#4223 closed Bug (duplicate)

Find button - Match cyclic - Message wrong

Reported by: bongobongo Owned by:
Priority: Normal Milestone: CKEditor 3.1
Component: UI : Dialogs Version: 3.0 RC
Keywords: Confirmed Cc:

Description

Hi.

I see that the find dialog have gotten a cyclic option (on by default). This is very nice.

But "Match cyclic" is working kind of counterintuitive:

Example I enter same word "this" a couple of times in the text in the editor, then I place the cursor after last occurence of "this" in the text, but not at end of the text though..

Then I click the Find button in the toolbar.

Then I enter the word "this" in the "Find what" in the "Find and Replace" dialog. Then I click the blue Find button in "Find and Replace" dialog.

Then I'm presented with the message: "The specified text was not found"

This gives me the impression that the whole text was searched and that the word was not found.

But in this case it was not so. The search routine has in the example above only searched from my cursor position and to end of text, but did not search in text above my cursor position.

If I click the Blue find button again after the message "The specified text was not found" was given, then it continues to search from top of document... and now it find the text I'm searching for.

As it is now, for an inexperienced user or an experienced superuser (under stress) can easily belive that message.

Suggestion: If the cursor is not placed at beginning of text when clicking Find button in the toolbar, then I suggest that the message "The specified text was not found" should not be displayed before the whole document has been searched.

If you cannot implement this, then hopefully you can give a more correct message to the user. E.g. "You have searched to the end of the document. The whole document has not been searched. Do you want to continue the search from top of the document?

If user then answer Yes, then I suggest the search automatically continues so user does not have to click the blue find button in dialog again to continue the search.

Or something like that.

I posted this as a bug, since the message given is not correct. (kind of buggy)

That said. This editor rocks. Keep up the good work.

Regards

Change History (3)

comment:1 Changed 10 years ago by bongobongo

Another thing:

Let say you have searched from beginning of text. And the search routine has found all the occurences of a given word, if you now click the Find button again in "Search and Replace" dialog then you get the message:

"The specified text was not found"

That is also kind of counterintuitive:

Would it not be better to say something like:

"You have searched to the end of the document. Do you want to continue the search from top of the document?"

If user then answer Yes, then I suggest the search automatically continues so user does not have to click the blue find button in dialog again to continue the search.

Just my 5 cents

comment:2 Changed 10 years ago by Garry Yao

Component: GeneralUI : Dialogs
Keywords: Confirmed added; find cyclic removed
Milestone: CKEditor 3.1

We would keep the way of how 'cyclic' working right now, since it's important to indicate user on document end, while the message could be changed to what you suggested.

comment:3 Changed 10 years ago by Tobiasz Cudnik

Resolution: duplicate
Status: newclosed

DUP of #3517.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy