Opened 10 years ago

Closed 10 years ago

#4226 closed Bug (worksforme)

EditorTag doesn't set value-attribute if the value is an empty string

Reported by: Toni Paloniemi Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

EditorTag doesn't set value-attribute if the value is an empty string. The value in this case is left to null, and user will see the text 'null' when using the editor.

Example on how to reproduce:

<fck:editor instanceName="demo" value="" />

The problem is in the EditorTag-file on lines 126 and 127:

if (Utils.isNotEmpty(value))
    fckEditor.setValue(value);

Either it should only check for null, or the value property of the fckEditor object should have a not null default value.

This problem began with version 2.5.

The workaround I use to get around this is to insert one space character as a value if my value is empty.

Change History (2)

comment:1 Changed 10 years ago by Toni Paloniemi

Ok, seems like this bug was only in the 2.5-beta-1 version. Updated to 2.5 and this was fixed

comment:2 Changed 10 years ago by Michael Osipov

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy