Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4232 closed Bug (invalid)

Safari + Toolbar wrapping

Reported by: mike890 Owned by:
Priority: Normal Milestone: CKEditor 3.1
Component: UI : Toolbar Version: 3.0
Keywords: Safari, Chrome Cc: Erik Kangas

Description

At least in the latest build there is a bug rendering long toolbars in Safari (tested with Safari 4 + Win Vista 64bit).

Unlike IE and FF, it does not wrap long toolbars and expands the editor by default to the width of about 700-800px even if the div that contains the editor is 500px.

Change History (7)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Toolbar wrapping removed
Milestone: CKEditor 3.1

comment:2 Changed 9 years ago by Erik Kangas

Cc: Erik Kangas added
Keywords: Chrome added
Version: CKEditor 3.0 RCCKEditor 3.0

I have confirmed that this bug affects the latest version of Google Chrome as well - v3.0.195.25 and Safari v4.03. Tested in Vista.

No matter what size area I put the CKEditor into, the tool bars do not wrap.

Works fine in IE, FireFox, and Opera.

comment:3 Changed 9 years ago by Erik Kangas

More information:

  • The "/" toolbar item does force a wrap (a hard wrap). This works in all browsers.
  • It is the separate toolbar segments within their own arrays [...] that do not wrap in Chrome and Safari. It's like they are not properly floating left.

Typically, we design our tool bars without any "/" hard wraps so that as the window size change, the toolbar can always take up the minimum amount of space needed.

also, I noticed in Chrome (didn't test Safari) that that collapse arrow has a good amount of space between it and the right-most toolbar segment. maybe 75-100px. In FF, that arrow floats right below everything and takes up minimal space.

comment:4 Changed 9 years ago by Erik Kangas

Interim workaround:

  • Use different custom configuration files for Safari (which includes Chrome) and everyone else. In the Safari version, use explicit "/" breaks where you expect most normal sizes will need them. For other browsers, leave off the "/" breaks so allow the number of rows to dynamically adjust.

comment:5 Changed 9 years ago by Garry Yao

Keywords: Pending added

Works for me in both Safari3.2 and 4.0, so I would ask you to please provide a sample page for reproducing.

comment:6 Changed 9 years ago by Garry Yao

Keywords: Pending removed
Resolution: invalid
Status: newclosed

Please feel free to reopen the ticket if you still have this problem.

comment:7 Changed 9 years ago by Erik Kangas

This bug does appear fixed in 3.0.1 - I have re-tested it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy