Opened 8 years ago

Closed 5 years ago

#4501 closed Bug (fixed)

jQuery-UI dialog does not work with CKEditor

Reported by: Almog Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.1
Keywords: Cc: luke@…, clobo@…

Description

when i locate the ckeditor on the jquery-ui`s dialog some inputs not work like "tables properties" etc..

Attachments (1)

ckeditor-jquery-ui.zip (306.5 KB) - added by Wiktor Walc 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added
Priority: HighNormal

Please provide a test case to check the problem.

Also take a look at the new jQuery adapter in CKEditor 3.1

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Pending removed
Summary: jquery-ui`s dialog NOT WORKS WITH ckeditorjQuery-UI dialog does not work with CKEditor

Changed 7 years ago by Wiktor Walc

Attachment: ckeditor-jquery-ui.zip added

comment:4 Changed 7 years ago by Wiktor Walc

Keywords: Confirmed added

I can confirm this bug, although don't know whether it's on our side since it looks like there is a solution for it in http://dev.jqueryui.com/ticket/4727

Anyway, steps to reproduce:

  • Launch index.html
  • Press the "Open Editor" button
  • Open Link Dialog
  • Try typing anything

comment:5 Changed 7 years ago by Lucas Holt

Cc: luke@… added

I've seen this bug as well. In our case, we have two CK Editors (3.1 and 3.2) on the same page (well a dojo popup div).

We are unable to type anything into any input box on the link dialog, but the drop downs work in advanced and the user can copy and paste using the mouse only. This is on Firefox 3.6.0 (FreeBSD) and Internet Explorer 6.0 (XP SP3).

comment:6 Changed 7 years ago by 3AMC

Cc: clobo@… added
Version: 3.4.1

I confirm that this behaviour is present in all browsers (IE, FF, Chrome, Safari & Opera) even with the the jquery patch (http://dev.jqueryui.com/ticket/4727).

Test done with :

  • ckeditor 3.4.1
  • jquery 1.4.2
  • jquery UI 1.8.4

There is no solution ?

Best regards.

comment:7 Changed 7 years ago by 3AMC

My apologize : the jquery patch work fine (a bad copy/paste).

comment:8 Changed 5 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

This issue is no longer reproducible in latest CKEditor 3.6.2.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy