Opened 10 years ago

Closed 10 years ago

#4511 closed Bug (fixed)

'cssFloat'/'styleFloat' problem break dt/core/dom/element.html

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: SVN (CKEditor) - OLD
Keywords: IE Confirmed Cc:

Description

IE8 has fixed 'cssFloat' style property which preserving the 'styleFloat' for backward compatibility, which induce our feature detection logic:

var cssFloat = ( typeof test.cssFloat != 'undefined' ) ? 'cssFloat'
	: ( typeof test.styleFloat != 'undefined' ) ? 'styleFloat'
	: 'float';

Attachments (1)

4511.patch (537 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Garry Yao

Attachment: 4511.patch added

comment:1 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: IE Review- added; IE8 Review+ removed

That's really weird... but it looks like this fix must be applied to all IEs. We need investigation.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

As I was wondering the TC is wrong, not the core code. In the TC, we're always checking the "cssFloat" property of the style, and we need instead to check styleFloat in IE only.

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review- removed
Resolution: fixed
Status: assignedclosed

You're right, the TCs have instead been fixed with [4341].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy