Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4524 closed Bug (duplicate)

Inconsistent processing of custom styles

Reported by: Damian Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version:
Keywords: IBM Pending Cc:

Description

There are some inconsistencies in the way certain style rules are applied and how they show up in the styles drop down. This is down to the lack of support for upper level elements including: <a>, <tr>, <td> etc.

When a style is added to the list of styles involving the use of an <a> tag, if it is through a custom plugin, it is listed as a <span> element, and if it is through the 'stylescombo/styles/default.js' file, it doesn't show up at all.

Change History (4)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Pending added

Sorry I don't understand the issue where, could you plz attach your styles definition to exemplify it?

comment:2 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Resolution: duplicate
Status: newclosed

I'm not sure about the second part as that looks like a bug in that custom plugin.

The first part is a summary of several tickets: #536, #667, #668, #717, #1053, #1897 Maybe there are other ones in Toolbar or in General

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

In fact, this is one of the new features we would like to propose in the 3.3. The ticket for it is #536.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy