Opened 8 years ago

Closed 4 years ago

#4533 closed Bug (fixed)

Opera: double-clicking undo/redo UI button can open "hotclick" context menu due to selection being restored by the editor

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version: SVN (CKEditor) - OLD
Keywords: Opera Cc: Hallvord R. M. Steen (Opera Software)

Description

To reproduce:

  1. Open CKEditor, type "This is some sample text"
  2. Make "This", "some" and "text" bold (to be sure that more than one action can be undone)
  3. Click Undo 3 times then just click randomly Redo and Undo
  4. Result:
  • browser's context menu is opened in the left corner of the browser

Attachments (1)

krst_13.46.06.png (45.7 KB) - added by Krzysztof Studnik 7 years ago.
Confirmed for Opera 10.61.3484, CKE 3.4.1 Trunk

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by Garry Yao

Component: GeneralCore : Undo/Redo
Milestone: CKEditor 3.x
Version: SVN (CKEditor)

That's weird ;)

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

Changed 7 years ago by Krzysztof Studnik

Attachment: krst_13.46.06.png added

Confirmed for Opera 10.61.3484, CKE 3.4.1 Trunk

comment:3 Changed 7 years ago by Garry Yao

The selection restoring is what makes Opera crazy, but we're not doing anything wrong here, so let's ask Opera for their opinion.

comment:4 Changed 7 years ago by Garry Yao

Cc: Hallvord R. M. Steen (Opera Software) added

comment:5 Changed 7 years ago by Hallvord R. M. Steen (Opera Software)

This is not the normal context menu, it's the "hotclick" menu that opens when you double-click something (contains commands that you would typically use on a selection). So if there is a selection when you "finish" two clicks that Opera thinks is a double click, it will appear.

It should be possible to avoid it with preventDefault() (though we've had a bug in the past that made it impossible and I'm not sure if that is fixed, need to look that up).

At least now you know why restoring a selection can cause a context menu :)

comment:6 Changed 7 years ago by Hallvord R. M. Steen (Opera Software)

BTW looked up the double click preventDefault() bug and it appears fixed. So you should be able to work around this if you choose to do so..:

document.addEventListener('dblclick', function(e){e.preventDefault()}, false);
  • though it would be user-friendlier to add it just on the element that contains the buttons, and not block double-click menu on the entire document.

comment:7 Changed 6 years ago by Hallvord R. M. Steen (Opera Software)

Summary: Opera: clicking on a redo/undo button opens context menuOpera: double-clicking undo/redo UI button can open "hotclick" context menu due to selection being restored by the editor

Still an issue

comment:8 Changed 6 years ago by Jakub Ś

This issue was duplicated in #7883

comment:9 Changed 6 years ago by Frederico Caldeira Knabben

Replying to hallvord@…:

I guess we should also consider not popping up the Hotclick menu if you double-click unselectable elements (assuming that the buttons are marked unselectable - right?)

This looks like a nice approach for it... we're not really dealing with double-click there, but with two single-clicks. It would be nice to have Opera understanding it.

comment:10 Changed 6 years ago by Hallvord R. M. Steen (Opera Software)

Reported DSK-338779 internally to suggest this.

comment:11 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Not reproducible in Opera 16.0.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy