Opened 8 years ago

Closed 8 years ago

#4609 closed Bug (fixed)

[FF2 FF3] Flash object is missing

Reported by: Joe Kavanagh Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: Core : Output Data Version: SVN (CKEditor) - OLD
Keywords: IBM Confirmed Review+ Cc: damian.chojna@…, matti.jarvinen@…

Description (last modified by Frederico Caldeira Knabben)

Using the ajax sample in either Firefox 2 or 3.

  1. Click the Create Editor button.
  2. Click the Flash button to open the Flash dialog.
  3. Enter the URL for the flash object and click OK
  4. Enter some text after the flash object.
  5. Click the Remove Editor button.
  6. Click the Create Editor button.
  7. Right click on the flash object and select Flash Properties from the context menu.
  8. Update a property in the General or Properties tab and click OK.
  9. Click the Remove Editor button.

The flash object is missing. Click the Create Editor button and observe the flash object within the editor.

Attachments (2)

4609.patch (970 bytes) - added by Garry Yao 8 years ago.
4609_2.patch (2.1 KB) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added

Confirmed. Additionally, the context menu doesn't open for the flash object after point 9, when creating the editor instance again.

comment:3 Changed 8 years ago by Matti Järvinen

Is #4552 related? Symptoms are similar and both use floatpanel.

comment:4 Changed 8 years ago by Matti Järvinen

Cc: matti.jarvinen@… added

comment:5 in reply to:  3 Changed 8 years ago by Frederico Caldeira Knabben

Replying to matti:

Is #4552 related? Symptoms are similar and both use floatpanel.

It should be totally unrelated.

Changed 8 years ago by Garry Yao

Attachment: 4609.patch added

comment:6 Changed 8 years ago by Garry Yao

Component: GeneralCore : Output Data
Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned
Version: 3.0SVN (CKEditor)

Browser just don't agree on the output of <param> and <embed> elements, some says self-close, others insist on self-open, just normalize them.

the context menu doesn't open for the flash object after point 9, when creating the editor instance again.

Seems to be another issue, worthy for a new ticket.

comment:7 Changed 8 years ago by Garry Yao

Adding fixes to the parser to treat flash related tags as block-like.

Changed 8 years ago by Garry Yao

Attachment: 4609_2.patch added

comment:8 Changed 8 years ago by Garry Yao

Ticket Test added at :
http://ckeditor.t/tt/4609/1.html.

comment:9 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:10 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [4453].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy