Opened 8 years ago

Closed 7 years ago

#4615 closed Bug (fixed)

Dialog fields are disrupted in RTL mode and IE

Reported by: Sa'ar Zac Elias Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: 3.0.1
Keywords: IE Cc:

Description

To reproduce:
go to the "multi-language interface" demo and choose Hebrew or Arabic (both languages are in RTL mode).
open the link dialog.
focus on the URL field, and notice that the marker is getting out of the box a bit to the right. write something and notice that the first character is also getting out of the box.

Attachments (4)

4615.patch (535 bytes) - added by Sa'ar Zac Elias 8 years ago.
4615.2.patch (1.5 KB) - added by Sa'ar Zac Elias 8 years ago.
Revised patch to fit all skins
4615_3.patch (1.5 KB) - added by Sa'ar Zac Elias 7 years ago.
Align patch with the recent changes
4615_4.patch (1.3 KB) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added

While I don't see the caret outside the box, I'm not even able to see it, as it looks like it's exactly over the border. There is no padding on it actually. It happens with all dialog fields actually.

Ok with Firefox.

comment:2 Changed 8 years ago by Sa'ar Zac Elias

Also in the Search and Replace dialog.

comment:3 Changed 8 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.3

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3CKEditor 3.x

comment:5 in reply to:  1 Changed 8 years ago by Sa'ar Zac Elias

Replying to fredck:

It happens with all dialog fields actually.

Actually i can't see the bug in all dialogs, just in some. this is quite odd since this is the same CSS definition.

comment:6 Changed 8 years ago by Sa'ar Zac Elias

Forgot to mention in the above, also in Selection field dialog.

Changed 8 years ago by Sa'ar Zac Elias

Attachment: 4615.patch added

comment:7 Changed 8 years ago by Sa'ar Zac Elias

Keywords: Review? added
Owner: set to Sa'ar Zac Elias
Status: newassigned

Changed 8 years ago by Sa'ar Zac Elias

Attachment: 4615.2.patch added

Revised patch to fit all skins

comment:8 Changed 8 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.xCKEditor 3.3

This is a small fix with no risk for a really annoying bug, so i hope it could get fixed in 3.3.

comment:9 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: HasPatch added; Review? removed

Thanks for the patch Saare. Let's wait for a core developer to ask for review.

comment:10 Changed 7 years ago by Sa'ar Zac Elias

Status: assignednew
Summary: URL field in the link dialog disrupted in RTL mode and IEDialog fields are disrupted in RTL mode and IE

comment:11 Changed 7 years ago by Sa'ar Zac Elias

Owner: changed from Sa'ar Zac Elias to --

comment:12 Changed 7 years ago by Garry Yao

Milestone: CKEditor 3.3CKEditor 3.4

comment:13 Changed 7 years ago by Sa'ar Zac Elias

Keywords: Review? added; HasPatch removed
Owner: changed from -- to Sa'ar Zac Elias
Status: newassigned

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 4615_3.patch added

Align patch with the recent changes

comment:14 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:15 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: assignedclosed

Fixed with [5665].

comment:16 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Review+ removed
Resolution: fixed
Status: closedreopened

I can still see this issue on trunk.

comment:17 Changed 7 years ago by Sa'ar Zac Elias

I'm not able to reproduce it in any way.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 4615_4.patch added

comment:18 Changed 7 years ago by Sa'ar Zac Elias

Status: reopenedreview

After a conversation with Fred we concluded that it's better to have a small spacing in some of the machines rather than not being able to see the caret in others.

comment:19 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: reviewclosed

:/ it still doesn't work for me.

I have then put 10px there... there is a lot of padding in the field, as expected, but the caret never shows at the start of the text, just at the middle of it.

This is definitely another IE bug, which impacts on just a few machines. Let's have a dedicated ticket for it, leaving this one as closed.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy